Dev API Outage
Incident Report for Medable
Postmortem
Cause

A routine update in our deployment layer resulted in network connectivity issues between nodes. This resulted in services that were functioning normally to appear down to load balancing and proxy services. This ultimately resulted in the api being inaccessible externally.

Resolution

Upon identifying the cause, we worked to re-establish connectivity internally, restoring load balancing and proxying services.

Prevention

New maintenance processes have been put in place for the nodes in question. Preventive maintenance measures will take place on non-production nodes that will allow for testing and verification of the updates before they can impact production services. In production, these updates will then be applied during scheduled maintenance so that the impacts can be closely monitored.

Posted Aug 29, 2017 - 22:15 UTC

Resolved
Dev API restored. We will update with details on the cause shortly.
Posted Aug 29, 2017 - 15:44 UTC
Update
The development api is experiencing an outage. We are investigating now and will update with more details as we have them.
Posted Aug 29, 2017 - 14:45 UTC
Investigating
We are currently investigating this issue.
Posted Aug 29, 2017 - 14:44 UTC